[packages/chromium-browser] requires _XGetRequest

Tomasz Pala gotar at polanet.pl
Wed Mar 13 18:38:17 CET 2013

On Thu, Feb 14, 2013 at 11:04:10 +0200, Elan Ruusamäe wrote:

> but if it's just pairs of such detections, so if you find 
> incompatibility, you register it once, and all packages being built with 
> affected library exceeding specific version at build time, gets version 
>  >= dependency at runtime
> benefit of this approach is that once incompatibility is found, any 
> other rebuild will get the fix automatically, without need to update 
> .spec files with a versioned dependency.

Another example catched, (some?) packages build with Qt 4.8 use
_ZNK7QLocale18nativeLanguageNameEv which doesn't exist in 4.7. I've just
pushed librecad with manual R: QtCore >= 4.8.0...

Tomasz Pala <gotar at pld-linux.org>

More information about the pld-devel-en mailing list