ruby-mail conflicts

Adam Osuchowski adwol at
Thu May 5 21:57:45 CEST 2016

poldek:/all-avail> freshen ruby-mail
Processing dependencies...
ruby-mail-2.5.4-3.noarch obsoleted by ruby-mail-2.6.4-1.noarch
error: ruby-mail-2.6.4-1.noarch (cap ruby-mail = 2.6.4-1) conflicts with installed ruby-rails-3.2.19-3.noarch (ruby-mail >= 2.6)
There are 1 package to install, 1 to remove:
I ruby-mail-2.6.4-1.noarch
R ruby-mail-2.5.4-3.noarch
This operation will use 809.7KB of disk space.
Need to get 226.0KB of archives (226.0KB to download).

error: 1 conflicts
There were errors

Is ruby-mail package obsoleted by ruby-rails? If so, why didn't old
version be removed?

More information about the pld-devel-en mailing list