problem with firefox 88

Jan Palus atler at
Wed May 5 14:00:43 CEST 2021

On 05.05.2021 13:44, Krzysztof Mrozowicz via pld-devel-en wrote:
> W dniu 05.05.2021 o 12:08, Jan Palus pisze:
>> On 05.05.2021 12:50, Krzysztof Mrozowicz via pld-devel-en wrote:
>>> W dniu 05.05.2021 o 11:35, Jan Palus pisze:
>>>>> Downgraded to version 87 and happy days.
>>>> Works for me. Did you try with fresh profile (firefox 
>>>> -ProfileManager), mozilla's binary (package mozilla-firefox-bin) 
>>>> and in case it still doesn't work stracing it?
>>> I tried with fresh profile - the same effect. It seems like FF is 
>>> reacting for clicking, but doesn't "re-paint" the interface 
>>> accordingly.
>>> When I, let's say click "+" to open a new tab, then minimize the 
>>> window and restore it, the new tab is there. Double-clicking on the 
>>> window title (maximize/un-maximize) also refreshes the interface. 
>>> Firefox 88 from mozilla-firefox-bin behaves the exact same way.
>>> Would you mind telling me how to strace the program in a correct 
>>> way, please? I did it few times in the past but always I was 
>>> googling the method.
>> Ah ok, somehow I thought firefox hangs or fails to start for you. 
>> That's probably an effect of enabling WebRender by default for 
>> XFCE/KDE with Intel/AMD GPU so likely for you. Try disabling 
>> webrender in about:config (|gfx.webrender.force-disabled=true). Which 
>> GPU? If Intel are you using modesetting driver?
> Zwycięstwo! Setting up the gfx.webrender.force-disabled=true made the 
> firefox usable again. Thanks Jan!
> Regarding the modesetting, I don't remember if I was tweaking any X 
> config about that. My hardware is:
> CPU: Intel(R) Core(TM) i7-2640M CPU @ 2.80GHz
> GPU: VGA compatible controller: Intel Corporation 2nd Generation Core 
> Processor Family Integrated Graphics Controller (rev 09)
> And xorg.log:
> # grep modesetting Xorg.0.log
> [    18.622] (==) Matched modesetting as autoconfigured driver 1
> [    18.628] (II) LoadModule: "modesetting"
> [    18.628] (II) Loading 
> /usr/lib64/xorg/modules/drivers/
> [    18.629] (II) Module modesetting: vendor="X.Org Foundation"
> [    18.632] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
> [    18.675] (WW) Falling back to old probe method for modesetting
> [    18.682] (II) UnloadModule: "modesetting"
> [    18.682] (II) Unloading modesetting
Not using modesetting on Intel is your real issue. Try to figure what's 
missing to make it work and webrender most likely will be fine in 
firefox. Anyway if you still have issues the discussion should be moved 
to pld-users-*

More information about the pld-devel-en mailing list