[packages/libvirt] + BR:leveldb-devel, libnl1-devel, libatomic_ops - BR:libnl-devel moved file cpu_map.xml to daemon
qboosh at pld-linux.org
Sat Dec 8 22:02:00 CET 2012
On Sat, Dec 08, 2012 at 08:20:10PM +0100, Grzesiek wrote:
> W dniu 08.12.2012 19:19, Jakub Bogusz pisze:
> >On Sat, Dec 08, 2012 at 11:58:13AM +0100, gzohop wrote:
> >>commit 29b6137ec4289c04d9bbf64a82aa53f3596f5ab9
> >>Author: Grzegorz Pycia / PLD <gzohop at carme-pld-i686.pld-linux.org>
> >>Date: Sat Dec 8 11:56:05 2012 +0100
> >> + BR:leveldb-devel,libnl1-devel,libatomic_ops
> >> - BR:libnl-devel
> >leveldb and libatomic_ops are ceph (RDB) dependencies, not libvirt's.
> >$ rpm -qR ceph-devel | grep -E 'leveldb|libatomic_ops'
> ceph-devel-0.53-2 does not require leveldb-devel or libatomic_ops, and
> this is the ceph available in th repos.
> What is the proper solution?
ceph is fixed in git after 0.53-2, before 0.54.
> Should libvirt require ceph-devel-0.54-1 to ensure that it can be build
Not necessary IMO, 0.53- can be assumed as broken packaging.
ceph rebuild is needed.
> >libvirt 1.0.0 builds with libnl 3.2+ just fine, doesn't need libnl 1.1
> It does not on carme:
> checking for LIBNL... no
> configure: error: libnl-devel >= 1.1 is required for macvtap support
Confirmed. It appears that libvirt uses the same libnl that netcf.
So netcf dependency needs to be bumped to 0.2.x (0.2.0?), when it
switched from libnl 1.1 to 3.x.
> On the other hand libvirt requires libpcap-devel which requires libnl1,
> should libpcap-devel rquire-libnl1-devel?
Currently no - it's internal dependency, not exposed in headers or
pcap-config (although it should be, if static libpcap was really
Jakub Bogusz http://qboosh.pl/
More information about the pld-devel-en